Filter - No Internet message on Android Devices

Overview

When using Securly SmartPAC or SmartDNS on Android devices some customers have noticed that a 'No Internet Connection" notification shows on Android devices. 

This is a cosmetic issue caused by the Android system trying to connect to google.com to validate that it has an internet connection.

Cause

The cause of this issue is that Securly SmartPAC and SmartDNS will inspect all traffic to google.com. The traffic which we return to the device has been re-encrypted with the Securly SSL certificate which the Android Operating system does not accept.

This is due to a concept called certificate pinning where the application or operating system will only accept a preconfigured certificate. As Securly SmartPAC and SmartDNS perform MiTM inspection on all Google traffic and re-encrypt with our own certificate the certificate we provide is not accepted and the message is produced by the Android OS.

Solution

There is no action required to resolve this message, as it does not affect the device's performance or the Securly Filter's effectiveness.

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