What are the system requirements for Pass?

During the implementation process, we provide clients with a detailed document that outlines all of the necessary system requirements to ensure that their Pass system operates correctly in their school, which includes the following:

  • A comprehensive list of domains to allowlist
  • Supported Browsers
    • Chrome
      • We prefer that clients use the past two major releases of Chrome, although the Pass system will run on older versions as well.  Many of our clients utilize Chromebooks, which are automatically updated with the latest OS versions for security reasons as well as functionality.  
    • Safari (iOS)
      • Our recommendation is that clients use the more recent iOS or iPads; however, some clients do experience some issues in functionality with older iOS versions.
Was this article helpful?
0 out of 0 found this helpful
Have more questions?
Submit a request

Comments

0 comments

Please sign in to leave a comment.

Articles in this section